Oct 082011
 

For various reasons I had to setup a Debian box. Debian 5.

For building software that would be distributed in binary form and should run on any linux.

The original software that mine derives from is being built on a debian 5 system.

So, I needed one as well.

Enter: VirtualBox for Mac + Debian 5 netinstall.

So far, so good, until I actually cloned my hg repo onto the deb box, and found that the clone had two heads.

… debian uses mercurial 1.0.1 on debian 5.

1.0.1.

seriously.

that is old.

very old.

It’s a miracle that debian has heard of unicode by now.

At least I think they have heard of unicode …

gotta check that.

  4 Responses to “Debian 5, or the joy of working with prehistoric software”

  1. Do you know that Debian 5 aka Lenny is not the most current Debian stable release? Squeeze is! I do not test with OpenSUSE 10.1 either and complain about old versions.

    And even for Lenny there is a backport of a newer version available:

    martin@merkaba:~> rmadison mercurial | cut -c1-72
    mercurial | 1.3.1-1~bpo50+2 | backports/lenny | source, alpha, amd64,
    mercurial | 1.6.4-1 | squeeze | source, amd64, armel,
    mercurial | 1.8.3-1~bpo60+1 | backports/squeeze | source, amd64, armel,
    mercurial | 2.0-2 | wheezy | source, amd64, armel,
    mercurial | 2.0-2 | sid | source, amd64, armel,
    martin@merkaba:~>

  2. Okay, and about Unicode. Debian uses UTF-8 since Debian Lenny by default.

    So when you rant, please do it *about facts*, not *myths* or *dice rolling* what might be the case.

  3. Before you try to start a flamewar, read the whole text:

    The original software that mine derives from is being built on a debian 5 system.

    So, I needed one as well.

    I have strict requirement to build the linux binary on a debian lenny. Can’t be helped.

    And I know about the backport of a newer mercurial, thank you very much.

  4. Well how about then to rant about that old software or that strict requirement instead of Debian? I received your blog post as a rant against Debian instead – especially the unicode stuff. And if you intended it as such, it should at least be based on the current stable version of it although Lenny came by default with UTF-8 as well.

    Otherwise I could rant about the crap that in OpenSUSE 10.1 or so was intended to be used for package management that sometimes wasn´t able to install a simple, small package within 15 minutes with 99% CPU using Zenworks Management Daemon zmd only SIGKILL-able then. But thats history as well and zypper now seems to be pretty good.

    See what I mean?

Leave a Reply

Optimization WordPress Plugins & Solutions by W3 EDGE
%d bloggers like this: